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Purpose and Scope

This document provides education and instructions regarding the improvements and new 
features inside the latest BLADE software. Follow theses instructions carefully to 
download the enclosed software and ensure all BLADE operators are aware of the changes 
made to the software.

The latest software for the BLADE wood processing system 
provides some valuable, time-saving features including:

• Automatic calibration monitoring and homing for 
Gripper, LASM, and Stroke.

• New Calibration screens with no measuring required!
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Small slotted 
screwdriver

Wire strippers
Overview

The software referenced in this document is:

• RX3i PLC software for BLADE wood processing system, v. 4.000.000 or higher

• BLADE operating software, v. 4.0.0.0 or higher

• Board Stretcher optimizing software, v. 4.1.45.0 or higher

The parts included in this kit are listed in Table 1. Please ensure all parts are present. 

Figure 1: RSDS Devices Included in Kit (version number may vary)

If you have any questions, call MiTek Machinery Division Customer Service at 
800-523-3380.

Table 1: Parts in SB218KIT

Qty. Part Description Part #

1 RDSD containing PLC RX3i software for BLADE 92280-504

1 RDSD containing BLADE & Board Stretcher software 92283

1 Jumper cable, 18-gauge 92053

1 Service Bulletin document SB218

! WARNING
ELECTROCUTION HAZARD!

All electrical work must be performed by a qualified 
electrician and in conformance with governing codes.

Only a qualified electrician, using the personal 
protective equipment and following the procedures 
recommended in NFPA 70E should ever attempt 
service or repair of or near an energized area or 
component of the machine.

Whenever maintenance is performed while the 
equipment is electrically energized, there is a potential 
electric arc flash hazard. Refer to NFPA 70E for the 
personal protective equipment required when working 
with electrically energized components. Pneumatic 
and hydraulic components may move unexpectedly if 
not de-energized. Physically restrain any components 
capable of movement when working on or near those 
components. 
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Downloading the Software

Downloading the PLC RX3i Software

The PLC software must be upgraded in order to work with the new BLADE software.

1. Before beginning:

a) Locate the supplied Removable Data Storage Device (RDSD) labeled 
Blade Updated PLC.

b) Ensure the saw disconnect handle is in the ON position.

c) Ensure the touch screen is powered on.

d) Shut down the BLADE software.

2. Prepare the PLC’s CPU to accept the new software update using these steps:

a) Locate the PLC CPU (IC695CPE305) in the main electrical enclosure. 
The CPU is shown in Figure 2.

AFTER the software is downloaded, the saw must be homed 
and calibrated EXACTLY as instructed on page 12. Follow this 
procedure in the exact order it is given.

If the RDSD is removed during data transfers to the CPU, the 
RX3i controller will generate a fatal fault (sequence store fault). 
You will need to clear the fault by power cycling the CPU with the 
Energy Pack disconnected before attempting to download again.
SB218 rev. D 4 of 22
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Figure 2: CPU for PLC

b) Open the small door on the CPU to expose the switches as seen in 
Figure 2.

c) Plug the Blade Updated PLC RDSD into the USB-A RDSD slot indicated 
with a.  in Figure 2.

d) Wait until the RDSD LED turns solid green. This indicates that the CPU 
has detected the RDSD and is ready for downloading.

e) Switch the RUN MODE direction switch to the left (STOP) position. It is 
indicated with a  in Figure 2.

f) Move the RDSD direction switch to the right (DOWNLOAD) position. It 
is indicated with a.  in Figure 2

Be very careful NOT to select UPLOAD. To upload means the 
program on the CPU will be loaded onto the RDSD, thus 
corrupting the program you are trying to download. If by accident 
you upload, contact Customer Service for a new RDSD.

Bottom Half of
Main Enclosure

CPU
(with door open)
SB218 rev. D 5 of 22
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DO NOT remove 
the RDSD from 
the CPU during 
transfer!

Transferring the 
software to the 
PLC should take 
approximately 
6-10 minutes.
3. Momentarily depress the START pushbutton to 
begin transferring the program to the CPU. The 
start button is indicated in Figure 3.

• If the RDSD indicator light blinks green, the 
program is downloading. It will become solid 
green once the download is complete. Once the 
download is complete, proceed to step 4.

• If the RDSD indicator light blinks red, this is 
acceptable. It has acknowledged that the 
program has a different name than what is 
currently loaded; momentarily depress the 
START pushbutton again. The RDSD indicator 
light should then blink green during the 
transfer.

• If the RDSD indicator light turns solid red, the 
transfer has failed. Perform these steps:

• Power down the PLC, wait a few minutes, 
then power it back up.

• Try repeating the entire process before 
contacting MiTek Customer Service for support.

4. When the RDSD indicator light turns a solid green, the transfer has completed 
successfully. Perform these steps:

a) Remove the RDSD from the CPU.

b) Return the CPU’s RDSD switch to OFF and the RUN MODE switch to 
RUN I/O ENABLE.

c) Validate the CPU is back in RUN mode by verifying the following is true:

• OK LED is solid green.

• RN LED is solid green.

• EN LED is solid green.

Errors are indicated when the RDSD LED becomes solid red (not blinking). 
All errors are reported in the Controller fault table and are written to a file 
on the RDSD. The fault tables are written to a file plcfaultafter.dat and 
iofaultafter.dat and can be viewed by MiTek Customer Service.

START

Figure 3: Start 
Button on CPU
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Downloading the BLADE Operating Software

To upgrade the BLADE operating software and take advantage of its time-saving features, 
follow this procedure.

1. Before beginning:

a) Locate the supplied 
Removable Data Storage 
Device (RDSD) labeled 
Blade Installer.

b) Ensure the saw disconnect 
handle is in the ON 
position.

c) Ensure the touch screen is 
powered on.

d) Shut down the BLADE 
software.

2. Save your current BLADE software 
folder to a different location to use 
as a backup in case the download 
gets interrupted.

a) Copy the folder: 
c:\program files 
(x86)\mitek\blade

b) Paste the folder in another location such as c:\backup. It is acceptable to 
overwrite existing files in the backup folder.

3. Insert the RDSD labeled Blade Installer into either of the USB ports on the side of 
the HMI (touch screen) enclosure shown in Figure 4. They may be located on the 
right or left side of the touch screen enclosure.

Figure 4: USB Ports on HMI
SB218 rev. D 7 of 22
Original Instructions



Service Bulletin SB218 
4. Browse to the RDSD (named TRANSCEND in Figure 5). Open the Blade 
Installer folder and double-click the Setup.exe file. See Figure 5.

Figure 5: Blade Operating Software File

5. The software should automatically display an Installer window to walk you 
through the installation process. Follow the prompts from the Installer.

6. When complete, open the BLADE software and go to Help>About to verify that 
the correct software version is showing in the window. Software version should 
display as: 4.0.0.0 or higher.
SB218 rev. D 8 of 22
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Updating KepServerEX Configuration

Kepware® software is the interface between the BLADE software and the PLC software. It 
must be upgraded in order to work with the new BLADE software.

1. Insert the RDSD labeled Blade Installer into one of the USB ports on the saw’s 
HMI. The USB ports are located on the outside of the touch screen enclosure, on 
either the right or left side, as shown in Figure 4 on page 7.

2. Start the KepServerEX 5 Configuration program using the desktop icon shown in 
the top half of Figure 6. If this icon is not on the Windows Desktop, find the same 
icon in the Windows System Tray (lower right of the HMI screen). It is shown in 
the bottom half of Figure 6. Once found, press and hold (same as right click) on 
the icon and select Configuration.

Figure 6: Two Ways to Open Kepware Software

Windows® 
System Tray

Kepware Icon on Desktop

Click       to 
see the tray. 
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3. Select File>Open from the KepServerEX 5 program.

Figure 7: From the File Menu, Select Open

4. Browse to the RDSD (named TRANSCEND in Figure 8). Open the Kepware 
folder and double-click the Blade for v3.0.16 and higher file.

Figure 8: Kepware File
SB218 rev. D 10 of 22
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5. Click Yes, Update.

Figure 9: Verify the Update

6. Verify the Kepware update was successful, before continuing to the next step. It 
should look like Figure 10. 

Figure 10: New Configuration
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Verify and Home the Saw

1. Verify on the HMI (touch screen) that the PLC version number has been updated. 
It is shown on the HMI by going to Diagnostics>Detailed Diagnostics>PLC tab 
located on the bottom half of the screen. The version number should display as 
4.000.000 or higher.

2. Home and recalibrate the saw EXACTLY as described here.

a) Home the Stroke axis only, by following these steps and Figure 11:

1) On the status indicators on the Home screen, select Stroke.

2) From the Stroke drop-down menu, select Home.

Figure 11: Select Home on the Stroke Menu

b) Reset the Stroke offset with these steps:

1) Go to Detailed Diagnostics and click the Stroke tab. Select the 
Home Offset RESET button.

2) A message displays explaining what will happen. Select YES.

c) Home the rest of the system by clicking the HOME SYSTEM button on 
the Toolbar.

d) The Ready light on the front of the touch screen enclosure illuminates 
when all axes are homed and ready to calibrate. Follow the procedure on 
page 17 to calibrate the following axes:

Gripper, LASM, and Stroke
SB218 rev. D 12 of 22
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Downloading the Board Stretcher™ Software

1. Before beginning:

a) Locate the supplied RDSD labeled Blade Installer.

b) Go to the computer(s) in your facility where board optimization is 
accomplished and ensure it is powered on.

2. Insert the Blade Installer RDSD into a USB port on the board optimization 
computer.

3. Browse to the RDSD (named TRANSCEND in Figure 12). Open the Board 
Stretcher Installer folder and double-click the Setup.exe file. See Figure 12.

4. The software should automatically display an Installer window to walk you 
through the installation process. Follow the prompts from the Installer.

Figure 12: Board Stretcher File
SB218 rev. D 13 of 22
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Adding Components

Adding a Jumper

Connect the supplied jumper cable (PN 92053) to the terminals indicated in Figure 13. 
This can be done before or after downloading the software, but it MUST be done before 
operating the saw in production.

1. Place one end of the cable into the terminal on the bottom of the FP2:2 terminal 
block, and tighten the screw.

2. Place the other end of the cable into the terminal on the bottom of the IN:36 
terminal block, and tighten the screw.

3. Gently tug on each end to ensure they are secure.

Figure 13: Connect Jumper Cable to Terminals on Bottom of Terminal Blocks

If the terminal is already used by an existing wire, secure 
both the existing wire and the new jumper at that terminal.

FP2:2 IN:36

Terminals in
Bottom Half of
Main Enclosure

Bottom of
Terminal 
Blocks
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Securing the Profinet Module

The Profinet Module is located in the main electrical enclosure and must be secured 
properly to avoid component damage. Failing to secure the Profinet Module may cause it 
to overheat and stop working, ceasing production on the saw. Follow Figure 14 to locate 
the screw and screw hole.

Figure 14: Snap the Profinet Module Into Place and Tighten the Screw

Screw

Profinet
Module

Screw hole 
in backplane.

BACKPLANE

Screw hole with cover.
Punch out cover 
to access hole.
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How to Use the BLADE Operating Software

All BLADE operators and maintenance personnel should study this section to properly use 
and maintain the BLADE wood processing system. Keep this section in the manual.

Homing Changes for: Gripper, LASM, & Stroke

This section applies only to the gripper, LASM, and stroke axes. The location of each axis 
is now monitored anytime the saw is operating in Auto Mode. It will automatically 
“home” itself in order to recalibrate the axis when needed. Since the saw never lets its 
home position become compromised, manual recalibration is rarely required.

The home z-pulse value no longer needs to be monitored or mechanically reset to be in the 
30000 to 100000 range since the new software no longer uses the z-pulse on the gripper, 
LASM, and stroke.

The primary reason the home position may become compromised and needs to home itself 
is that a jam in any given axis may cause the motor collar to slip. The motors are designed 
to let this happen to avoid costly damage. By automatically homing itself, occasional slips 
are planned for and dealt with automatically. But, if the saw is experiencing a high number 
of out-of-calibration instances on a certain axes, the root cause must be determined and 
fixed. If the saw reads 4 or more slippages on the same axes within an hour, it gives the 
following error: The xx servo has mechanically slipped many times in a short duration. 
The Online Support button will display a web page with information on how to eliminate 
this issue. Online Support is accessible from this error, from the saw’s Home Screen, and 
from our web site.

Tech Talk

The counts do not reset at 4, but continue to count up within any 60-minute time frame. 
Online Support describes all the points to check on each axis. The way it tracks the axis 
position and the accuracy it requires is shown in Table 2

Table 2: How It Tracks the Position

Axis
Measures 
Inaccuracies

How it Tracks Position

Gripper >3/32”
Reads where trailing edge of board passes beam of 
Leading Edge Sensor (receiver/transmitter pair on front 
end of Infeed Rail), and beam reconnects.

LASM >1/16”

Uses LASM Lockout Sensor (also called No Fly Zone 
sensor) to tell when LASM is directly in front of blade (if 
blade is at 90 deg). As LASM moves toward outfeed 
side and passes sensor, position is captured.

Stroke >1/16”
Uses Home Sensor on retract motion to capture 
position.
SB218 rev. D 16 of 22
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Refer to...
Figure 15
Figure 16

Refer to...
Figure 17

Refer to...
Figure 18
Figure 19
Calibration Changes

This section applies only to the angle, bevel, elevation, and CLS axes. The other axes are 
kept in calibration with the automatic homing feature.

New Calibration Procedure

1. Ensure the status banner on the HMI shows READY. You may need to press the 
HOME SYSTEM button on the Toolbar if the system is not in the Ready state.

2. Place the saw in Manual Mode.

3. Go to Tools>Calibrate.

4. Select which axis to calibrate and choose START. Only calibrate the axis that 
requires it. Overcalibrating can cause other system complications.

5. Follow the instructions on the screen. What happens next is listed in Table 3.

Table 3: What Happens During Calibration

Axis What Happens Select Indicate

Angle

With a flat saw blade, 
cuts 7 plunges at top of 
board, at different 
angles. The height of the 
raised areas on each 
side of a cut are to be 
focused on.

Pick the cut that 
has the raised 
areas on both 
sides of it at 
approximately the 
same height.

On the Calibration 
screen showing on 
the HMI, press the ID 
letter that is printed 
next to your 
selection.

Bevel

Cuts 14 plunges (7 pair). 
1 pair = 1 partial cut, 
then flips blade 180° and 
makes cut in same 
place, with stroke slightly 
retracted.

Pick the pair with 
the cuts in exact 
same place (or 
closest to).

On the Calibration 
screen showing on 
the HMI, press the ID 
letter that is printed 
next to your 
selection.

Elevation

10 plunges, creates stair 
steps in bottom of wood. 
In calibrated saw, the 
first 5 don’t touch the 
wood.

Count the # of 
stair corners 
visible on the 
board that are 
complete semi-
circles.

On the Calibration 
screen showing on 
the HMI, press the # 
matching the number 
of stair corners.

CLS
Performs a “stability check”. Determines if the CLS sensor eye is failing 
to sense the board because it is not physically aligned with the board 
location or if there is a sensor and/or electrical issue.
SB218 rev. D 17 of 22
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Graphics Supporting Calibration

Figure 15: Angle Calibration Screen

Figure 16: Angle Cut

Figure 17: Bevel Calibration Screen
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Figure 18: Elevation Calibration Screen

Figure 19: Elevation Cut
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Create Straight Board Feature

It is still vitally important to use a straight board when calibrating any axis. A new feature 
has been added that trims one edge of a board to ensure a straight, flat edge for calibrating 
certain axes. The CREATE STRAIGHT BOARD button has been added to the Calibration 
screen, and is available at any login level. It is grayed out until the saw is in Auto Mode 
and the saw blade is started. Once the CREATE STRAIGHT BOARD button is pressed, 
the saw rips across the top of a board to create a straight edge that can be trusted for certain 
tests. Always use this method to create a straight edge for CLS and Elevation Home 
calibration.

New Rip Bevel Fields

In the Key-In screen, new 
fields and a diagram have 
been added labeled Rip 
Bevel. It allows the 
operator to set the short 
side to a specific 
dimension in order to 
create specifically-sized 
blocks or boards that are 
not in a Job file.

Figure 20: New Rip Bevel Fields

 

SB218 rev. D 20 of 22
Original Instructions



Service Bulletin SB218 
Errors You May See

Solution to Possible Stroke Error

Depending on where the Stroke z-pulse is located when the HOME SYSTEM button is 
pressed, in rare cases, the stroke axis will retract all the way to the hard stop and display an 
error. To remedy this:

1. Go to Diagnostics>Detailed Diagnostics in the BLADE software at the HMI.

2. Click the Stroke tab.

3. Click the RESET button circled in Figure 21.

Figure 21: RESET Button on Stroke Tab
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Solution to Z-Pulse Error

If during calibration, either of the messages shown in Figure 22 or Figure 23 are shown for 
any axis, take the following steps.

Figure 22: Error SRV006

Figure 23: Error SRV002

1. From the HMI’s Home Screen, go to Diagnostics>Detailed Diagnostics, and 
select the tab for the axis that the error indicates.

2. Select the CLEAR Z button to clear the error. The Stroke screen is shown in 
Figure 21 on page 21 with the CLEAR Z button circled.

END OF SERVICE BULLETIN
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