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Getting Started 
— 
Overview 
Board Stretcher is a program that helps you optimize your use of lumber. It is installed on one or 
more computers in the production office.  

There are three steps to optimizing with Board Stretcher. The process can be automated or 
manual. 

1. Import design files for roof/floor trusses or wall panels.  
Supported file types include: .OMN/.CUT/.DAT/.XML/.MIZ/.MME 

2. The parts are automatically placed onto stock length boards. They are arranged to 
minimize waste or lumber cost. 

3. A cutting file is output for the saw.  
Supported file types include: .XML/.MDB/.MIZ 

The program has a dedicated Lumber Yard for each saw. Set up the available grades, sizes and 
lengths that you have in your physical yard, and the program will make the most efficient use of 
the material. 

This manual documents the stand-alone installation of Board Stretcher. 

 

Optimization: How it Works 
The program can optimize according to waste or cost. 

The optimization method is as follows:  

1. All imported parts are sorted into grade and then into size. They are sorted in 
descending order. 

2. The longest part is placed first. It is placed on the longest stock length of the same grade 
and size. 

3. The program considers if any parts will fit on the remainder of the board. It will identify 
two parts: 

a. The part with the best matching angle to the preceding part. 

b. The longest part that will fit on the remainder. 



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 7 of 97 

4. The program compares the amount of waste or the material cost and identifies the part 
that achieves the lowest waste or lowest cost. 

5. The longest part is then placed on the next size of stock length (if applicable), and the 
program rechecks the same two factors to find the best optimization for the parts on that 
stock length. 

6. This is repeated for all stock lengths within the grade and size to see if the parts can be 
combined more efficiently. 

7. After all stock lengths have been checked, the stock length with the lowest waste 
percentage or the lowest cost is selected. 

8. This process is repeated for the next longest part and continues until all parts are 
placed.  

There are several ways to customize the optimization, including using Lumber Penalties, Grade 
Replacement, Lower Grade Fill and Remainders.   

 

About this Manual 
• Standard lengths are used for most images. See Add Lumber to the Lumber Yard for 

information on inputting stock lengths. 

• If a field or option is not in this manual, it may relate to older saws, previous program 
versions, or a system default. Do not change these defaults unless you are asked to do 
so by a MiTek representative. 

 

Terminology 
The following terms are used in this manual. 

• Kerf: The width of the saw blade, including the material removed by a saw stroke. 

• Lumber: A board or group of boards. Various grades, sizes and lengths.  

• Boards: A specific grade, size and length of lumber. The saw uses boards to create 
Parts. 

• Parts (cut parts): The final cut part that is used in assembly. This piece of board is cut 
to the exact size and shape required for the truss, floor or wall panel. 
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Opening and Closing the Program 

To open: Select the desktop shortcut  or Board Stretcher.exe.  

The default location is C:\Program Files (x86)\MiTek\BoardStretcher. 

To close: Go to File > Close.  

 
Select Clear to close a job file but keep the program open. 

 

Access Levels 
Your access level is shown at the bottom right of the program. 

 

Standard Operator Access 

This is available on start-up without a login. 

Admin Access 
You need admin access to change some settings. 

 
1. Go to File > Log in. 
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2. Type the username and password. 

3. After editing the settings, go to File > Log out. 

Note: See Troubleshooting if you have issues with the password. 

 

Settings Migrator 
The Settings Migrator is a fast and accurate tool to transfer your Saw Profile settings.  

It can be used to copy settings when: 

• Upgrading to a new version of Board Stretcher.  

• Installing Board Stretcher on a different computer.  

• Installing Board Stretcher at a different site. 

Tip: Multi-site manufacturers can use the tool to set up a saw at one site, export the 
settings and use the settings.json file to set up the same saw at other sites. 

Export 
1. Select the Saw Profile on the sidebar that you want to export. 

2. Go to Tools > Export/Import. 

3. In the dialog: 

a. Select Settings to export the Saw Profile, its Lumber Yard and configuration 
settings (including settings in the Options dialog such as file paths).  

b. Select Replacement Grades to include Higher Grade Replacement and Grade 
Replacement settings in the export. These settings are separate because 
different sites may require different grade substitution options. 
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Note: The buttons are gray when they are selected. 

 
4. Select Export.  

5. Save the settings.json file. 

Import 

1. Go to Tools > Export/Import. 

2. Select Import in the dialog. 

3. Select the settings.json file to import. 

4. The Saw Profile configuration settings (and Replacement Grades, if included in the 
export) will be imported to the selected Saw Profile. 
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Saw Profiles 
— 
Overview 
Each saw you use with the program needs to have a Saw Profile. Profiles allow you to 
customize your settings for the capabilities of each saw. For example, some of your saws may 
be able to process 20ft boards and some may be limited to 16ft, or you may have different 
printing or angle/bevel capabilities on different saws. 

One saw can have multiple profiles. We recommend setting up a separate Saw Profile for each 
type of component you put through the saw, i.e., one saw has separate profiles for roof trusses, 
floor trusses and wall panels. This allows you to customize how the program optimizes each 
type and set up component-specific Lumber Yards, print options and other settings. 

If you change a profile when a file is already imported, you must Clear the file (from the ribbon, 
File > Clear) and import it again to apply the options.  

 

Add a Saw Profile 
1. You need Full control access to any folders used by Board Stretcher. Use the Folder 

Permissions section in Troubleshooting to check whether you have the correct access 
before adding a Saw Profile. 

2. Select the BoardStretcher profile on the sidebar. 

 
3. Go to Tools > Options. 

4. Go to the Machines tab. 
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5. Change Name to the name for the profile. This can be any name that allows you to 
identify the saw and the purpose of the profile. The name is displayed in the Saw Profile 
sidebar. 
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6. Your IP address should be populated automatically. It is used to connect to the 
database. 

• If your IP address does not change (i.e., it is static), do not change the address.  

• If your IP address changes regularly, type “localhost”, and an address will be 
shown that is not affected by IP address changes. Your IP address may change 
if, for example, it is regularly reassigned by the Internet Provider or you use a 
laptop and multiple networks. 

7. Change Type to the type of saw. Use the drop-down to select it. 

8. Select Add. 

9. A dialog will be displayed. Type the saw Name at the end of the file location. This is the 
name input in step five. In the example below, the saw Name is Blade-2. 

 
10. A dialog will be displayed. Select Yes. 

 
 

Note: You may need to repeat steps eight and nine. If you receive an Application 
Error, check that you have Full control access to the location, see Troubleshooting: 
Folder Permissions. 

 
11. The Saw Profile will be added to the list at the top of the Options dialog. Select Accept 

to close the dialog. 



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 14 of 97 

 
The saw will be displayed on the Saw Profile sidebar: 
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12. Go to File > Close. This completes the initial saw setup. Open the program again and 
continue with Customize Saw Profiles to set up the saw for use. 

Note: If you need to create multiple Saw Profiles at the same time: follow steps one to 
eleven for each saw and once all saws are added, follow step twelve to complete the initial 
setup on all new Saw Profiles. 
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Customize Saw Profiles 
— 
Overview 
Once a Saw Profile has been added, you need to customize the file locations, pick list options, 
printing and optimization methods. 

1. Select the Saw Profile on the sidebar. 

 
2. Go to Tools > Options. 

Many of the options will be set up by the MiTek representative during installation. The 
information below is a guide to the settings. 

 

General Tab 

Moving Average 
This setting relates to a DirectDrive™ installation with the BLADE™ saw. Do not change this 
default unless you are asked to do so by a MiTek representative. 
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“Blade-1” (Name of Saw Profile) Tab 

 

Machine Name 
This is the name of the Saw Profile. You can change the name of the saw on this tab. The name 
is shown in the Saw Profile sidebar. 

 

Frame Number 
BLADE saw serial number. 

Use Legacy XML Format 
Check this option when using the Omni-Miser™ II saw. This allows .XML files to be imported 
and exported to this saw. 

User Display: Display and Input Units 

Select Imperial (feet and inches) or Metric (millimeters).  

• Imperial measurements are provided using three pairs of numbers. For example, 12-06-
08 is 12 feet, 6 inches and 8/16 inches (12' 6-1/2"). 

• Metric measurements are provided in whole millimeters. 
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Note: When changing display and input units, the same unit must be chosen in the 
BLADE saw software before optimizing the job. 

Square Cut 
Set the angle that the saw uses as a reference for square cuts. The default BLADE saw 
reference is 90°. 

 

Machine Linear Tab 

Kerf 
Set the blade thickness by inputting the default for a new blade i.e. 0.210. This must be correct 
because the program considers the kerf during part placement, lumber selection and 
optimization. 

Replace Grades 
You can set up compatible grades for missing lumber and the program will automatically replace 
the missing lumber with the alternative during import. These options save time, for example, if 
you have taken overflow jobs from other manufacturers that stock different grades. Select Yes 
to enable the grade replacement options on the Grade Handling tab on the ribbon and then set 
up the Higher/Grade replacements. 

Maximum Part Length 
Set the maximum part length according to the infeed for the saw. 

Importing Parts with End/Rip Bevels Allowed 
Check this option when setting up a BLADE Saw Profile. 

If the profile is for a saw which cannot make angle or bevel cuts (e.g., some older versions of 
the Omni-Miser™ I), check this option to cut the part at overall length and mark the angle or 
bevel cuts. The part can then be finished using a chop saw. 

Remove End/Rip Bevels from Parts when Imported 
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Do not check this option when setting up a BLADE Saw Profile. 

If the profile is for a saw which cannot make angle or bevel cuts (e.g., some older versions of 
the Omni-Miser I), check this option to remove parts with end/rip bevels from the file during 
import. You can then import the file manually and process the parts with end/rip bevels on a 
compatible saw. 

Default Lumber Penalties 
These penalties provide a way to set up Lumber Penalties on the load source. Typically, loading 
from the automated bunks would be preferred. Setting a small penalty against the magazines 
and a higher penalty against manual feed would discourage the program from using boards 
from these sources unless necessary. 

Note: This feature has been replaced by the ability to set Lumber Penalties on individual 
board lengths. A penalty system on the boards provides greater customization and may 
improve your optimization. See Lumber Penalties for more information. 

Reset Optimization Settings 
Do not use these unless you are asked to do so by a MiTek representative. 

 

File Import Tab 
This tab allows you to manage file imports and exports. Import locations are set up separately 
for manual imports (started manually by a user) and auto imports (typically triggered when a file 
is sent from a batching program, e.g., MVP®, CyberSort™). There is one default export folder 
for manual and automatic exports and the saw will process files in this folder. 

MVP Tip: To find the file path to your saw 
files: 

1. Open the Saw Shop. 
2. Right-click on the saw and select 

Properties.  
3. Copy/paste the file path shown in 

Saw File Destination. 
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Manual Import Folders 
The top section of the File Import options relates to file locations for manual import. 

 
There are three possible locations for default manual import folders. You do not need to use 
them all. 

Auto Import Users 

We recommend that one of the manual import folder locations is the Invalid folder. This allows 
you to import files with errors and fix the issues manually. The remaining options can be left at 
the default location or customized, if you want to import other files manually. 

Manual Import Users 

If you use manual import only, you can use the multiple locations to organize your files into job 
types, i.e., roof trusses, floor trusses and wall panels. Follow the steps below to set up a manual 
import location. 

Manual Import Location Setup 

The quickest way to set your import folder location is to find it in Windows Explorer and copy the 
location address. 

1. In Windows Explorer, left-click in white-space in the location bar. 
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2. The location will change to a path. Right-click in white-space in the location address and 

select Copy from the menu. 

3. Go to Board Stretcher. 

4. Select the Saw Profile on the sidebar. 

5. Go to Tools > Options. 

6. Go to the File Import tab. 

 
7. Left-click in the Manual Import folder field to activate the field. 

8. Right-click in the same place and select Paste from the menu. 

The location will be pasted correctly from Windows Explorer. 
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Tip: Using Browse in the program will also allow you to navigate to the correct folder. 
CTRL+C / CTRL+V can be used instead of selecting Copy/Paste from the right-click 
menu. 

 
9. (Optional) In Display label, type a short name to be shown above the file location in the 

Import dialog. This can be very useful for identifying file locations with long or complex 
names. 

Example: 

 
10. Select the file extension for the files you are importing from your design software into the 

program. The following file types can be imported: 

a. .MIZ – Wall panel design files, typically exported as .MDB for the Omni-Miser I.  

b. .OMN/.CUT/.DAT –  Roof truss design files, typically exported to linear saws, 
e.g., Servo-Omni™, Auto-Omni™. 

c. .XML – Universal file type, typically exported as .XML to the BLADE saw and 
Omni-Miser II. 

d. .MME – File type used in Asia-Pacific. 

11. After import: Choose what to do with the file after it has been manually imported. In 
most cases, we recommend checking None.  
 
You can use Rename to identify files that have failed Auto Import and have been 
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manually imported from the Auto Invalid Transfer folder. See Auto Import: Managing the 
Auto Invalid Folder. 

12. Export Ext: Set the file extension for the files you are exporting from Board Stretcher to 
be imported by the saw. Select .MIZ or .MDB if your Saw Profile is an Omni-Miser I or 
select .XML if your Saw Profile is a BLADE and Omni-Miser II. 

Export Folder 
This is the default folder for optimized files. The saw will process the files in this folder. Use 
steps one to eight from Manual Import Location Setup to add the folder location. 

Note: If the saw is not on the domain, but is compatible with USB drives, files can be 
copied from the Export folder to a USB drive and loaded onto the saw from the drive. 
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Remote (Auto Import locations) 
Check Enabled to use Auto Import.  

This feature allows files from your batching program (e.g., MVP, CyberSort) to be imported, 
optimized and exported by Board Stretcher for the saw to process. See Auto Import for more 
details about the process. 

There are several locations related to Auto Import. The folders are created by default and 
should be placed on a network drive. As a user, you need to have the permission level of Full 
control over these folders (see Troubleshooting: Folder Permissions). 

Example: 

The top level folder name is the Saw Profile, i.e., Blade-1, followed by RemoteFiles and then the 
name of the Auto Import folders.  

 

Tip: Using these naming conventions will help MiTek Automation Support to provide 
faster guidance. 

 
Auto Import Folder (WIP) 

This is the location that Board Stretcher watches for original files to import, optimize, and export 
automatically. This folder must not be used for other types of files (e.g., pick lists or attachments 
etc.). It is called WIP by default, which means that this is a “work-in-progress” folder where files 
are sent before they are imported. 
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Auto Valid Transfer Folder (Valid) 

Original files are moved here when Auto Import (import, optimization and export) is successful. 
These files are the original, unoptimized files. The optimized files are sent to the default Export 
location. 

Auto Invalid Transfer Folder (Invalid) 

Original files are moved here when there is an issue with the file and Board Stretcher cannot 
process it. 

Note: Add the same file location as one of your manual import folders to allow you to 
import the file manually and fix the issues. An Auto Process Errors report can be printed to 
notify you that a file has an error. See Reports: Error Report Overview for more 
information. 

 
There are two further folder settings below the Auto Import locations. 

 

Auxiliary XML Output Folder 

Set the export location for an unencrypted version of the XML file (.XMLA). See Output 
Auxiliary XML (.xmla) for more information about this option. 

Backup Folder 

Set the location for the backup of the SQL database. Do not change this default unless you are 
asked to do so by a MiTek representative. 
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Wall Panel Tab 

Square Cut Only 
Check this option if the saw cannot make angle or bevel cuts, e.g., some older versions of the 
Omni-Miser I. 

3 x Search Pattern 
Do not use this option unless you are asked to do so by a MiTek representative. 

Add Part Print 
Check to enable printing on wall panels. 

Flip Print (.MIZ only) 
Check to adjust the location of the print on the top and bottom board so the printing can be seen 
easily. 

Regex 
Do not use this option unless you are asked to do so by a MiTek representative. 

 

Reports Tab 
See Reports for more information about the Lumber and Board Pick Lists and the error report 
for files that fail Auto Import. 

 

Print Tab 
The print options relate directly to the saw type and available printers. If AGS™ printing is 
available, set your print options according to the installed print options. Example print options 
are also shown in Part Information. 

Consider what type of information you need on parts when setting up print options. Prioritize 
your options to ensure the most important information is printed. Options are not printed if they 
do not fit on the part. AGS printing is prioritized above custom print fields.  
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Printer #1 to #3 
Check Available for use on the relevant sides/edge and specify the valve type.  

7-valve high (1 inch) text print will be used if there is not enough room for 16 or 32-valve high 
print or if the Small print only option is active (see below). 

Print Head Options (BLADE saw only) 

Small Print Only  

Standard print height is a maximum of 4 inches. Small Print Only restricts the height to a 
maximum of 1.5 inches. This saves ink and the print may be easier to read because there is 
more space between each print option and the custom print field (if applicable). 

Edge For Trusses 

Print the same information on the edge of the truss that is printed on the front of the truss 
(excluding plate layout). This option allows you to see the job name, overall length, etc., to 
identify trusses quickly when stacked. 

Truss Print Justify 
These options determine where the text will be printed on each part. Leading Edge is the right 
edge and Center will position the print at the center of the part. Trailing Edge (left edge) is 
most often used because it places the print closest to the stacker. 

Print Options 

Braces 

Include printing on purlin bracing for chords. 

Assembly Guide System 

Use AGS printing options (BLADE saw only). When used in conjunction with a MatchPoint 
Blade™ wood processing system, the BLADE Printer allows you to print member level 
information to assist in the truss or wall panel assembly process. The different printing options 
are outlined in Table 1 and Table 2. Refer to the image below Table 2 for face definitions. 
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Table 1 

Option Description 

A Standard with every saw. Prints standard print fields on front face. 

B Uses two print heads to print standard print fields, joint and plate information, and 
joint alignment marks on face-up (on assembly tables) side of board. 

C Same as A, plus a second print head to print on the top edge of the board. 

D Same as B, plus a third print head to print on the top edge of the board. 

E AGS+: Uses two print heads to print everything in B, plus plate outlines in correct 
location and basic graphics on the face-up side.  

Tip: Best return on investment for truss assembly. 
 

F AGS+: Same as E, plus a third print head to print on the edge of the board.  

Tip: Best return on investment for wall panel assembly. 
 

 

Table 2 

 # of Valves Front Rear Edge Face-Up Side (on assembly tables) Front Rear Edge 

 Front Rear Edge Standard Print Fields Joint 
# 

Align. 
Marks 

Plate 
Size 

Plate 
Outline 

Graphic Wall Marks 

A 16 0 0 X           

B 16 7 0 X X  X X X      

C 16 0 7 X  X      X  X 

D 16 7 7 X X X X X X   X  X 

E 32 32 0 X X  X* X* X* X X    

F 32 32 7 X X X X* X* X* X X X  X 

 

* Print can be moved toward the top or bottom edge of the board so it is closer to the joint. 
 
If you are unsure of the saw configuration, contact MiTek Automation on 800-523-3380. 
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Face vs Face-Up 

 
 

Top Plate Outlines (AGS Plus) 

Print can include joint alignment marks for intersecting parts (e.g., locations for webs joining 
chords), joint number, plate size, outline, orientation and graphics (e.g., your company logo). 

Bottom Plate Outlines 

Plate size and orientation are printed. Select this option if you flip the truss to place the bottom 
plates and need an additional plate location on the back side. 

Disable Part Types 

Do not print webs. 

Bottom Label 

Print the plate label only on the back of the truss. Turn on Bottom Plate Outlines for plate size 
and orientation. 

Tips:  
• Custom print fields are set on the Assembly Profile tab. 

• 32-valve printheads are required for front and rear to print braces, plate outlines 
and bottom labels. 
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Assembly Profile Tab 

Select Assembly Type 
Select whether the saw is used for trusses (roof), wall panels or floors. 

Lower Grade Fill 
Check to allow the program to automatically take parts and place them on a higher grade 
material if there is space on the end of a board. See Grade Handling: Lower Grade Fill. 

Optimization Method 
There is a balance between achieving good parts optimization and maintaining the efficiency of 
assembling the parts. 

• Standard: All parts in the file are optimized together. This will mix parts from all 
assemblies in the exported file. Consider your assembly processes and capacity when 
exporting from your batching software. Aim to take advantage of optimizing multiple 
assemblies while ensuring that the roofs/floors/walls can be assembled on the tables 
efficiently. 

• Strict: Optimize each truss separately. Strict optimization also requires the Out Board 
Sort Order to be set to Import File Order. This option ensures that parts are exported in 
an order which allows the assembly of one truss at a time. The optimization may not be 
as effective because fewer parts are involved, but there may be time and cost benefits 
during assembly for customers with fewer staff and tables. This option maintains the 
batching applied in MVP or CyberSort. 

Optimization Basis 
Select to minimize Cost or Waste during optimization. Waste (Length Penalties) is most 
commonly used. The Cost basis (Cost Penalties) requires a user to maintain the cost of the 
materials in Board Stretcher. 

Batch 
Select Yes to cut truss by truss. Enable Strict in Optimization Method to optimize each truss 
separately. 

We recommend creating a specific Saw Profile (and a specific MVP profile, if used) for cutting 
truss by truss to avoid changing your usual configuration to suit this output. This allows you to 
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quickly switch to truss by truss for small runs or when cutting particular truss types to ship them 
together. 

Create Batch Data 
Use this option to customize the batching applied by MVP, CyberSort or ShopNet.  

You can split one file into different batches and export them as one file. Alternatively, you can 
combine multiple files into one batch with one export file.  

You can also use this option to create batches without batching software. 

Use the Batch tab, on the Assembly Profile tab, to create the batches. 

Batching is useful if you want to:  

• Optimize each job name, group, truss, assembly, description (e.g., all chords or all webs 
to go to one saw) or MVPTrussItemId separately. 

• Optimize specific trusses together. 

• Optimize the exported files for different saws. 

Use Lumber Penalties 
Select Yes to enable Lumber Penalties. See Lumber Penalties for more information. 

Export/Import Tab 

Output Auxiliary XML (.xmla) 

The exported XML file is encrypted. If you need to use the final optimized lumber data to update 
your ERP or inventory software, check this option and add a location for the exported .XMLA 
files in the Auxiliary XML Output Folder field (on the File Import tab). 

Invert Batch Order 

This option can be used when cutting truss by truss or panel by panel. It reverses the batch 
order provided by the production software. The program will optimize truss by truss/panel by 
panel, in the reverse order. This can be useful if you need to flip the order that the trusses are 
bundled after the saw file has been produced. 

To enable Invert Batch Order, change the following settings on the Assembly Profile tab in the 
Options dialog: 

1. Set Batch to Yes. 
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2. Set Optimization Method to Strict. 

3. Set Out Board Sort Order to Import File Order. 

4. Select Accept to close the dialog. 

5. Reopen the dialog again (Tools > Options > Assembly Profile). 

6. The Invert Batch Order checkbox is now available. Check the option. 

7. Select Accept to close the dialog. 

 

Out Board Sort Order  

See Customizing Reports. 

  



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 33 of 97 

Custom Print Fields Tab 
This tab allows you to specify what information is printed. 

Tip: Check what the saw can print before setting Custom print fields. See Print options for 
a quick guide to AGS print options. 

 
Print Selection 

Select Default to print the JobName, Description and Quantity (of like parts). 

Select Custom and use the table to set which fields/information you want to print. Each row is 
one type of print that can be customized to a particular length. The rows print in the priority 
order shown in the table, starting at the top of the table. To change the priority, left-click on a 
field within the row and use the arrow buttons to move the row. The Add button allows you to 
include another print field. Highlight a field and select Remove to delete the row from the table.  

 
Field 

Use the drop-down to select the field to display. Many fields are taken from the file (see Parts > 
Part Data) and are self-explanatory. 

• OverAllLengthFraction: For Imperial measurements, select this field to display 
measurements with standard punctuation instead of hyphens. For example, 8-6-3 will be 
printed as 8' 6-3/16". 

• Side: Print L or R to show whether the part is assembled on the left or right side of the 
truss. This option is typically used for wider spans. Parts can be sorted into separate 
carts or piles for assembly. The truss is divided at the peak to determine L and R.  
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• AOSide: The same option as Side, but the truss is divided at the center of its span to 
determine L and R. 

• Text: Print any custom text. Select Text in the Field drop-down list and input a short 
string into the Text column. The text will print directly before the next custom field. For 
example, you could add “qty” to print directly before the Quantity field, or you could print 
your company name at the end of each truss.  

• PartHighSide: Print an arrow (< or >) to show which end is up. The arrow points to the 
end of the part that is higher (closer to the top of the truss) when it is assembled. No 
arrow is printed if the part is horizontal once assembled. This option is available for 3D 
file types and must be exported as .XML (BLADE saw). 

 
Column and Length 

The Column and Length options allow you to specify the exact part of a field to print. This is 
useful when the full field includes common characters or information that does not need to be 
printed. These options can make the print easier to read and reduce ink usage.   

• Column: Set where to start the print, counting from the left. Type “1” to start from the 
leftmost character. 
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• Length: Set how many characters to display from the starting character set in Column. 
The start character is included in the print. 
To set the Length, we recommend checking the standard sequence for a field and 
increasing this by at least two characters to ensure that all are captured. If the field only 
has four characters and you have allowed for a Length of 6, only four characters will be 
printed. For JobNames in particular, this ensures that when the number increases to the 
next ten or hundred, it will still print the increased number of characters. 

 

Example 1: 

The customer’s Description field can include at least three characters.  

 
All characters need to be printed on the truss. 

1. Select Description in Field. 

2. Type 1 in Column to start the print at the first character, i.e., “B”, “W”, or “S”. 

3. Type 5 in Length to print all characters, i.e., “B3”, “W3”, or “ST7”, and leave the potential 
for an increase in the characters. 

 

Example 2: 

The customer’s JobName field includes leading zeros at the start and the date at the end.  
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“12345” needs to be printed on the truss. Increasing the Length to account for increasing 
numbers will not work in this case. 

1. Select JobName in Field. 

2. Type 6 in Column to start the print at “1”. 

3. Type 5 in Length to print five characters, i.e., “12345”. 

 
Result: 

 
When the JobName reaches the next digit, i.e., 0000100000, change the Column value to 5 
and the Length value to 6 to include the full number. 

Batch Tab 
When creating batch data in the program (see Create Batch Data), this tab allows you to specify 
how the assemblies are batched. The table functions the same as the Custom Print Fields tab. 

 

Messaging and Alerts Tabs (Board Stretcher Profile Only) 
These settings relate to a DirectDrive installation with the BLADE saw. Do not change these 
defaults unless you are asked to do so by a MiTek representative. 
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Lumber Yard 
— 
Overview 
The lumber types stocked at your facility need to be added to virtual Lumber Yards for each 
saw. To optimize parts, the program needs to match the lumber required in the job file with the 
lumber in the saw’s virtual Lumber Yard. 

We strongly recommend that you build your Lumber Yard for each Saw Profile by importing files 
using manual import. All fields must match the job file exactly, including upper or lower case, 
spelling, punctuation and spaces. Using the lumber specifications from the job files will ensure 
that there are no entry errors. 

Add Lumber to the Lumber Yard 
The following sections describe adding lumber from an imported file, adding lumber manually 
and replacing lumber with a suitable existing grade. Lumber Penalty input is an advanced 
feature and is covered separately in the Lumber Penalties section. 

Note: Stock Length Input 
 
Actual length should be used when adding material to your Lumber Yard. The program 
adds the saw kerf to the overall length required for parts.  
 
Example: Two 8ft parts cannot be cut from a 16ft board that is input as 16-00-00. 
However, the 16ft board is likely to be between ¼in or ⅜in longer than 16ft. This 
measurement needs to be included in the stock length to allow the program to use the 
board. 
 
We recommend measuring a sample of each length of board in your yard to find the 
average measurement for each standard length. This average length should be input as 
the stock length in the Lumber Yard. 
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Tip: Increase the size of the Required Lumber area to ensure you can see all entries.  
Position your mouse cursor below the area until the arrow changes into the icon shown 
below.  

 
Hold down the left mouse button and drag the area down until all rows are visible. 

 

Add Lumber from an Imported File 
When you import a file, a warning is shown if the Lumber Yard is missing the grades or 
dimensions required for the file. 

 
Select Yes to open the Lumber Yard in a new window. 

1. In the Lumber Yard window, under Required Lumber, the field In Stock will be 
unchecked if the lumber is missing from your Lumber Yard. 
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2. Double left-click on the Id you want to add. 

3. Left-click Add to Manuals. 

 
The lumber grade, size and length are added to your Lumber Yard. Note that the Materials ID is 
missing. This is the unique number for a grade and size of lumber that MVP and Management™ 
use to track and manage your lumber usage. Note: This feature is not currently available for 
wall panels. 

 
4. Hold down the left mouse button on the same Id, drag it to the entry in your inventory, 

and release the mouse button to copy the Materials ID. 
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5. If you want to add multiple lengths of the same lumber, complete steps one to three 

again and use the Length drop-down list to change the length. If the length required is 
unavailable in the drop-down list, left-click on the Edit field for the row and adjust the 
length value in the Edit dialog (shown below). 

 
 

Note: Pre-existing Lumber 
If you find that the required lumber is already in the Lumber Yard but there is a difference 
in upper/lower case, punctuation or spaces: 

• If it is an error in the file and the existing entry in the Lumber Yard is correct, use 
the guidance below for Replacing Lumber with a Suitable Existing Grade.  

• If it is not an error and the file contains the correct format for the lumber, add it to 
the Lumber Yard and delete the existing entry if it is incorrect. 
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Add Lumber Manually (Without a File Imported) 
1. Select the Saw Profile on the sidebar. 

2. Double left-click on the Id field. 

3. Left-click Add to Manuals. 

 
4. A new line will be added at the bottom of the inventory. 

 
5. If the lumber grade, size or length has been input before, use the drop-down lists on 

each field to select them. This ensures your input is consistent with the rest of your 
Lumber Yard. 

If they do not exist, left-click the fields and type in the information. Alternatively, left-click on the 
Edit field for the row and change the values in the Edit dialog. Use the same format and naming 
conventions as the design files to ensure that they are compatible with your Lumber Yard. 

6. The Materials ID is unique to a grade and size; e.g., No. 2 SPF 2x4 will have a different 
Materials ID to No.2 SPF 2x6.  

a. For an existing lumber grade/size:  
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i. Left-click on the existing Materials ID and press CTRL+C to copy the ID.  

ii. Left-click in the new field and press CTRL+V to paste the ID. You can 
also type into the field. 

b. For a new lumber grade/size: when the first file is imported that uses the same 
Materials ID, copy the ID from the Required area in the Lumber Yard (see step 
four of Add Lumber from an Imported File). 

7. Add more grades/sizes/lengths as required. 

8. Select OK. 

 

Replace Lumber with a Suitable Existing Grade 
This option can be used in several situations: 

• If you have taken a job from another manufacturer that stocks different grades. 

• If you have no stock of the required grade. 

• If the text in the Grade or Size field is slightly different to your Lumber Yard.  
For example, the file has a Grade of “2x4 SPF No.2”. Your Lumber Yard has the same 
grade and size, but the size is not stated in the Grade name. 

 

Note: Check availability 
Check that the replacement lumber is physically stocked in the inventory (or will be 
available when the sawyer is ready to cut the parts). The replacement boards are not 
checked against the physical inventory software. 

 
1. In Required Lumber, on the missing lumber row, left-click in the white area of the In 

Stock field. Any lumber in your inventory with suitable dimensions will be highlighted in 
green. 
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2. If the grade is a suitable replacement, select it in the Grade drop-down list. 

3. Select OK. 

Select Yes on the following warning. 

 
The Required lumber is now using one grade for all boards. 

 
4. Select OK to close the Lumber Yard. 

5. Optimize the file and export it to the saw. 

  



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 44 of 97 

Lumber Yard Management 

Set Lumber as Out of Stock/In Stock 
You can uncheck the Enabled field to set the lumber as out of stock. The lumber will not be 
used during optimization. 

 
If an imported file requires out-of-stock lumber, follow the process for Replace Lumber with a 
Suitable Existing Grade or Add Lumber to the Lumber Yard. 

Check Enabled again when the lumber is back in stock. 

Remove Lumber from the Lumber Yard 
You may need to permanently remove lumber if you no longer stock a specific item or remove 
lumber that was input incorrectly. Left-click on the Edit field for the row and use the Delete 
button. 
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Grade Handling Tools 
— 
Overview 
The Higher Grade Replacement and Grade Replacement tools allow you to set up alternatives 
when the exact lumber in the file is not available in your Lumber Yard. Once customized, Board 
Stretcher will automatically change missing lumber grades to stocked grades. The replacements 
can be set for all lumber in a grade or specific sizes in a grade. 

Lower Grade Fill is an optimization option, allowing the program to place parts on the end of 
higher-grade boards. 

The three options are available under Grade Handling on the ribbon. 

 
Missing lumber will cause the Auto Import to error. Files with errors need to be manually 
imported, optimized and exported. Setting up Higher Grade Replacement and Grade 
Replacement will save time by reducing the issues caused by missing lumber. 

 

                                         DANGER 

You must ensure that the replacements are structurally equivalent. MiTek 
accepts no liability for errors with these settings. 

 

Higher Grade Replacement 
Use this tool to set up grades that can be placed on a higher-grade board.  

This option is typically used when you are out of stock of the requested grade for a long time. 
Using a higher grade may be more cost effective than delaying the job. 

 

Grade Replacement 
Use this tool to set up equivalent replacements. 
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There are several situations where you could use grade replacement: 

• You have accepted overflow jobs from other manufacturers that stock different grades. 

• You are out of stock of a particular grade. 

• You process job files that refer to the same grade or size differently. 

• Example: You receive files that ask for “SPF No. 2” and “No.2 SPF”. You could also 
receive files that refer to the same size in different ways, such as “2x4”, “2X4”, and “2 x 
4”. There should only be one entry in your Lumber Yard for a specific grade and size. 
Grade Replacement allows you to take account of these alternative naming conventions. 

 

Set up Higher Grade or Grade Replacement 
Firstly, enable Replace Grades in the Options dialog: 

1. Select the Saw Profile on the sidebar. 

2. Go to Tools > Options > Machine Linear. 

3. Set Replace Grades to Yes. 

Note: You may prefer to choose replacement grades on a job-by-job basis. If so, do not 
set up Higher Grade Replacement or Grade Replacement. When the file causes an error 
during Auto Import, use manual import and select a higher grade or equivalent grade 
material to replace missing grades before optimizing the file. See Replace Lumber with a 
Suitable Existing Grade. 

 
Secondly, go to Grade Handling on the ribbon and select Higher Grade Replacement or 
Grade Replacement to set up the replacements. 

1. Specify the lumber that needs to be replaced. 
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2. In Grade, left-click the drop-down arrow and select the required lumber if it is in the list. 
If it is not in the list, left-click in the Grade field and type the lumber grade. 

Note: This entry must match the entry in the job file, including upper or lower case, 
spelling, punctuation and spaces. Using the lumber specifications from the job files will 
ensure that there are no entry errors. 

 
3. In Replacement Grade, left-click the drop-down arrow and select the grade from your 

Lumber Yard to use as a replacement. If it is not in the list, left-click in the Replacement 
Grade field and type the lumber grade. 

Note: This entry must match the entry in your Lumber Yard, including upper or lower 
case, spelling, punctuation and spaces. 

 
4. The Width and Depth columns allow you to restrict the replacement to specific sizes. 

• To replace only 2x6 lumber, type “6” in the Width column and “2” in the Depth 
Column. 

• To replace 2x8 and 2x10 but not 2x4 and 2x6 etc., create two replacements: one 
for 2x8 and one for 2x10. 

Leave the fields empty to apply the replacement to all sizes. 

5. Select OK to save your changes. 

Both replacement tools are run and applied during import. 

Tip: You can remove a replacement by checking the box at the end of the row and 
selecting OK. 
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Lower Grade Fill 
Use this option to place parts on the end of higher-grade boards.  

There are two main benefits to Lower Grade Fill: 

• You can avoid the additional cost of using another full board of lower grade lumber and 
avoid creating more remainders/waste. 

• The remainder area on the higher grade may typically go to waste.  
If the end of a board can be used for Lower Grade Fill or a Remainder, the Lower Grade Fill is 
prioritized. 

Set up Lower Grade Fill 
Firstly, enable the Lower Grade Fill option. 

1. Select the Saw Profile on the sidebar. 

2. Go to Tools > Options > Assembly Profile. 

3. Set Lower Grade Fill to Yes. 

Secondly, select Lower Grade Fill on the ribbon to set up the replacements. 

The dialogs for all three replacement types are very similar. See the description above for 
Higher/Grade Replacement. 

Lower Grade Fill is then applied when the file is optimized. 
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Material Handling Tools: Remainders 
— 
Overview 
Remainders allow you to cut useable lengths from board waste. They can be set up at the 
BLADE saw or set up in Board Stretcher.  

When you set up remainders in Board Stretcher, you specify the remainders you want to cut 
and set them in priority order. Once the parts in a job are placed during optimization, the 
program considers if there is any usable space left on the boards to cut one or more 
remainders.  

• You can see how remainders will be placed on the boards in the Board Graphics tab. 

• You can see board and lumber efficiency (see Board Data, Lumber Data and 
Optimization). 

Note: Using remainders does not increase your lumber usage. Remainders are not 
considered as parts. Remainders will only be placed if there is enough usable space left 
on a board that already has parts placed on it. 

 
Example: 

2x4 4ft, 2ft and 14.5in remainders are active for all grades and set in priority order from longest 
to shortest. 

 
On the Board Graphics tab, you can see the program has placed all three lengths on one board 
in order of priority. 
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The 4ft remainder is placed first after the part, but the remaining waste is not long enough for 
another 4ft, so a 2ft remainder is placed. The remaining waste is not long enough for a 2ft, so 
14.5in blocking is placed. 

 

Stock Sizes and Grades 
Remainders can be set for all grades or specific grades only. For example, you may want to use 
Utility or No.2 SPF for wall blocks and set the more expensive grades for remainders of longer 
lengths. 

In the dialog, each stock size is separated by a gray header. The selected remainder is 
highlighted in light blue. 

Example:  

2x6 and 2x4 stock sizes, each with a priority order. The 14.5in blocking is currently selected. 

 
 

Optimization 
The effectiveness of the optimization with remainders is affected by the stock lengths in your 
Lumber Yard, the remainders you want to cut and the jobs themselves. The example below 
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shows the optimization results for the same job and the same remainder setup, but with different 
stock lengths in the Lumber Yard. 

1. 16ft boards only 

2. 16ft and 18ft boards 

3. 16, 18, 20ft boards 

4.  8, 10, 12, 14, 16, 18 and 20ft boards 

 
The Length effectiveness without remainders increases as the number of stock lengths 
increases. At the same time, the percentage of remainders cut decreases.  

The Total length effectiveness remains high in all cases, showing efficient use of waste when 
remainders can be cut. 

Tip: Remainders can be used to build a stock of smaller lengths instead of buying them. 
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Add a Remainder 
1. Select the Saw Profile on the sidebar. 

2. Go to Material Handling > View Remainders. 

3. Select Add in the dialog. 

 

4. Double left-click a part profile to select the angle cuts required. Select profile 1 for 90° 
cuts.  

 
 

Tip: If you require angles or bevels on the remainders, you could select 90° cuts to 
keep production running smoothly and finish the cuts on a chop saw. 
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5. Select the grade you want to use for the remainder. Select None if you want all grades 
to be included. Add multiple remainders if you want to apply it to some but not all grades.  

6. Type the Overall length of the remainder you want to cut. 

7. Select the stock size (do not change stock length, as long as the length is longer than 
the remainder). 

8. Select Validate and draw. 

9. Select Add. 
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Remainder Management 

Changing Priority 

Select a remainder and use the arrows   to change the order in which the program places 
the remainders on boards. Order the remainders with the longest length first. If the shortest 
length, for example, blocking, is first, the remainders will almost always be cut to the shortest 
length. 

Deactivate or Delete a Remainder 
Deactivate remainders if you want to stop producing the length temporarily. This is useful if you 
have too much stock of a particular length.  

Double left-click a row to toggle between active/inactive or select a row and select Change 
activation. In the example below, the 2ft length is deactivated and the program will only try to 
place 4ft and then 14.5in remainders. 
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Leading Waste/Trailing Waste 

 
Check the option for your saw. The BLADE saw cuts remainders from the leading waste only. 
Omni-Miser I and II saws cut remainders from trailing waste only.  

Desc. 
Select to view the remainder that will be cut 

 

Station 

Specify where the rollers send the remainders after cutting. DirectDrive installation only. 

Grade 
Select the grade you want to use for the remainder. Select None to include all grades. 
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Importing Files 
— 
There are three ways to import files. 

Import 

• Manually select one or several files for import.  

• Selecting multiple files will batch them.  

• View parts, review the optimization and fix errors. 
Auto Process 

• Manually select multiple files for import.  

• The files will be processed and optimized individually.  

• This method provides quicker import/processing times than Import, but you can still 
review and fix errors. 

Auto Import 

• The program watches a specific file directory (usually the export location from MVP, 
CyberSort or ShopNet) and automatically processes each file individually.  

• Individual files are not combined into batches. 

• Errors are reported. 
 

Each option has benefits, and which options you use will depend on your processes.  

See the following sections for more on each type of import. 
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Manual Import: Import and Auto Process 
— 
Overview 
Import and Auto Process both allow you to: 

• Import one file or multiple files. 

• View the parts within a file. 

• Review the optimization statistics.  

• Fix any errors in the file. 
The key difference between Import and Auto Process is how they handle multiple files. 

• Import — Multiple files are processed, optimized and batched together.  

• Auto Process — Multiple files are queued. The files will be processed and optimized 
individually.  

We strongly recommend that new customers use Import, followed by Auto Process for several 
weeks before changing to Auto Import. This has many benefits, including: 

• Building up your Lumber Yard by using copy/paste from real job files to reduce errors. 

• Working with your MiTek Representative to customize the optimization options for your 
company’s needs. 

• Learning how to fix issues with job files that cause errors during Auto Import. For 
example, an error will occur if the file contains lumber that does not match exactly with 
your Lumber Yard. 

 

Manually Import a File 
1. Select the Saw Profile on the sidebar. 
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2. To use Import, go to File > Import.  

 

To use Auto Process, go to Commands > Auto Process. 

 

The following steps are the same for both Import and Auto Process. 

3. Select Get Files next to the default location for your file. If the file is not in the default 
folder, use the Windows dialog to find the file. For default file location set-up, see Manual 
Import Location Setup.  

You can select multiple files by holding down CTRL or SHIFT as you select them. 
Import — The files will be optimized together and combined into one export file.  
Auto Process — The files will be queued, imported in turn, and exported as individual 
files. 

4. A warning will be shown if the Lumber Yard is missing the lumber grades or lumber 
dimensions required for the file. Select Yes to open the Lumber Yard in a new window. 

 
5. In the Lumber Yard window, the In Stock field (under Required Lumber) will be 

unchecked if the lumber is missing from your Lumber Yard. You can replace the required 
lumber with a suitable existing grade or add the missing lumber to your Lumber Yard. 
See Replace Lumber with a Suitable Existing Grade or Add Lumber from an Imported 
File. 

6. The Status Bar shows the total number of parts.  
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The status cells are color-coded: 

• OK — Green: Successful import, no issues with the file. 

• Warning — Yellow: Warnings are typically addressed during optimization, but 
the warning will still be displayed. The file can be exported. 

• Error — Red: Files with errors can be optimized but the part causing the error 
will be removed from the optimized file and the export. 
For more information about Warnings and Errors, see Part Errors. 

 

7. Go to Commands and select Optimize. You can also stop the optimization from this 
ribbon, if required. 

 
8. Once optimized, the Status Bar shows the total number of boards used and the total 

number of parts placed on the boards.  

 
9. Use the tabs to review the optimization. The Boards > Board Data tab shows the waste 

lengths and efficiency data per board.  
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10. The Boards > Lumber Data tab shows the optimization for each length of lumber. This 

includes the total board length (footage), the total length efficiency, and the total waste 
lengths after all parts have been cut. 

 
See Viewing Imported Files for more information about each tab.  

You can also go to Report on the ribbon and check that the Boards Pick List and Lumber Pick 
List have the correct Out Board Sort Order options for the file. See the Out Board Sort Order 
options for more details. 

You can optimize the file again if you make changes in the Saw Profile options or the Lumber 
Yard that affect the active file.  

Once you are satisfied with the optimization, the file is ready for the saw. 
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Note: If you want to cancel the import and clear the file from Board Stretcher, go to File > 
Clear. Do not use Delete. 

 
11. Go to Commands > Export. This export creates the optimized file for the saw. 

 
12. The default export location will be shown in the dialog. Select Save.  

 
See File Import Tab for how to change the default export location. 

13. The Board Pick List and Lumber Pick Lists will be created if they are active in the Saw 
Profile options. See Running Reports. 

14. If Auto Process is used, the next file is now imported. Start again from step four. 

Tip: The same file can be imported into the program again, either as the original 
unoptimized file or as the exported, optimized file. 
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Auto Import 
— 
Overview 
This feature allows you to import, optimize, and export files automatically. The standard 
workflow is shown below. 

¹ See Running Reports, Automatic. 

² See Auto Process Errors report. If this report is not enabled, the Auto Invalid Transfer folder 
will need to be checked regularly for files with errors. 

 

Tip: You can manually copy/paste or drag/drop files into the Auto Import “WIP” folder and 
they will be processed automatically. 

 

Setup 
There are three folders used by the Auto Import process: Auto Import, Auto Valid, and Auto 
Invalid. See Remote (Auto Import locations) for more information.  

After setup, the Auto Import process only requires user involvement when there is an error 
during processing. 

 

 

The batching 
program (e.g. 
MVP, Cybersort) 
sends a file to the  
Auto Import 
folder 

The file is 
imported, 
optimized and 
exported by 
Board Stretcher 

Successfully 
processed 

Error during 
processing 

The original, 
unoptimized file is 
moved to the 
Auto Valid 
Transfer folder 

The original, 
unoptimized file is 
moved to the 
Auto Invalid 
Transfer folder 

The Lumber 
and/or Board Pick 
Lists are 
printed/saved¹ 

A notification 
error report is 
printed² 

The saw 
accesses the 
Export folder 
and processes 
the file 
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Common Errors 
If a file has an error, find the file in the Auto Invalid folder and use manual import to fix the 
issues. See Part Errors: Auto Import for examples of common errors. 

Managing the Auto Invalid Folder 
A file with an error will stay in the Auto Invalid folder after you have used manual import to fix 
the error successfully. To avoid processing the same file multiple times, we recommend you 
either: 

• Manually move the file to the Auto Valid Transfer folder after successfully exporting it 
using manual import. 

• Use automatic renaming to change the file extension on the file after it has been 
manually imported. Follow the steps below to enable this option. 
1. Go to Tools > Options > File import.  

2. If you have not already done so, change one of your import folder locations to the 
Auto Invalid Transfer folder location. For more detail on this setup, see Manual 
Import Location Setup. 

3. Type Invalid as the Display label. 

4. In Extension, select the real extension of the input file.   

5. In Export Ext, select the real extension for the export file. 

6. In After Import, check Rename and change the extension on the file to a “fake” 
extension, e.g., ZML. 

7. Select OK to save your changes. 

When checking for new files that have failed Auto Import, select Import > Get Files on the 
Invalid folder location. You will only see XML files by default. 
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When you select All Files in the extension drop-down list, you will see the .XML and the .ZML 
files. 

 
This renaming allows you to keep the files, mark that they have been successfully actioned and 
only view them when necessary. 
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Viewing Imported Files 
— 
Overview 
This section describes the Tab bar. This area shows you detailed information about the 
imported file and the optimization. 

 
There are four primary tabs: Parts, Boards, Assemblies and Optimizations. The Parts and 
Boards tabs have secondary tabs. 

The rows alternate between green and white in most tabs to make the screen easier to read. 

 

Parts 

 

Part Graphics 
View 2D and 3D representations of the parts.  

Controls 

• Right-click on a part to select View Part (view the part in 3D in the Part Information 
window) or Edit Part. 

• Double left-click in white space (not on a part) to flip all the boards over. 

Part Data 
This tab lists the parts that will be exported to the saw. 
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Most fields in the Part Data tab are self-explanatory.  

• The Id is the unique identifier for the part. 

• OA Len. is the overall length of the part. 

• Group is the wall panel bundle ID. 

• Assembly is the truss. Wall panels do not have an assembly; the Wall panel ID is 
typically included in the description.  

• Description is the part label. 

• Qty. For trusses, this is the grouped quantity of a particular part. A line with a quantity of 
0 is added to allow the assembly to be shown on the Assemblies tab. For wall panels, 
quantities are not combined; each is shown with a quantity of 1. 

Right-click on a row to select View part or Edit part.  

• View part: View the part in 3D in the Part Information window. You can also double left-
click on a Part Data row to open the Part Information window. 

• Edit part 

Note: Build Station displays which table the part will be delivered to when using Board 
Stretcher with a DirectDrive installation.  

Part Errors 
This tab shows warnings and errors when the file is manually imported. 

Warnings 

Files with warnings can be optimized and exported. The Status changes to Warning to notify 
you of an issue. 

 
You will see the warning if you are using manual import. For example, the warning “Invalid part 
– the stock length is less than the overall length” is addressed during optimization. In this case, 
the program will use a longer stock length to ensure that the part can be cut.  
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You will not see the warnings if you are using Auto Import. Files with warnings are 
automatically optimized and exported. 

 

Errors 

Manual Import 

During manual import, files with errors can be optimized but the part causing the error will be 
removed from the optimized file and the export. In Parts > Part Data, “X” is displayed in the 
Has Error field on the affected part. 

 
The error will be shown in Parts > Part Errors. In the example below, the infeed is 16ft which is 
not long enough to process the part.  

 
To process the part, use manual import on a Saw Profile with an infeed over 19ft. Edit the 
quantity of all other parts to 0 to avoid duplication (see Change the Quantity of a Part), optimize 
and export the file.  

 

Auto Import 

During Auto Import, files with errors cannot be imported, optimized or exported until the error is 
fixed. The file is moved to the Auto Invalid Transfer folder to allow you to manually import the file 
and fix the errors. The most common error occurs when the requested lumber is unavailable in 
the Lumber Yard. When you manually import the file, this error will display as a warning dialog 
immediately after import. 
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Typical errors 
• Parts are too small for the saw to cut.  

Example: wedges under 3 inches in length cannot be cut by the BLADE saw. 
Exporting a file with this error is reasonable because the parts would need to be 
removed from the file and processed at a chop saw. 

• The length of the part is longer than the infeed.  
Example: 20ft boards are required but the Saw Profile only has a 16ft infeed. This 
error requires a profile that has a 20ft infeed. If this is not possible, an engineer 
could make changes in the design file to reduce the length of the part. 

• Characters included in the print that cannot be printed.  
This includes ", used in some software to indicate inches. Designers should avoid 
most punctuation in the file, apart from dashes – and underscores _. The following 
characters cannot be printed and will cause an error: . ' " : ; ()[]{}/\ . These should 
be removed from the design file before importing the file again. 

 
 

Boards 

 

Board Graphics 
View 2D representations of the parts placed on the boards. These are the optimized positions 
for the parts. Each board shows the Part ID, Assembly and Description for each part placed. 

 

Controls 

• Use the scroll wheel to zoom in and out and the scroll bars to view all the boards. 

• Left-click on a part to view it in 3D on the Part Information window. 
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• Double left-click in white space (not on a part) to flip all the boards over. 
A red line is shown on boards that have short parts. 

 
This line indicates that the program has shifted all parts to the right (front) to place the maximum 
number of parts on the board. The front of the last part must be placed to the right of the red line 
for the gripper to secure the board during cutting. Remainders can still be cut from the board, if 
there is space between the last part and the red line. 

 

Part Information 

Left-click on a board to view the Part Information. This window displays the part in 3D. The 3D 
view includes saw printing (see Options > Print). See the BLADE saw printer guide (or 
equivalent for the specific saw) for detailed information on printer setup. 

1. Joint numbers. 

2. Joint alignment marks for intersecting parts, e.g., location for webs to join a top/bottom 
chord. 

3. Plate perimeter location. 

4. The length from the end of the part to the start of the print mark. 

5. Custom print fields. See Custom print fields for more information. 

6. Plate size and orientation. 

7. Purlin bracing for chords (see second image). 
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Note: Ensure that the BLADE saw and Board Stretcher configurations are the same. 

    

Controls 

• Rotate the part: Position your cursor on the part, hold down the left mouse button and 
move the mouse up or down. 

• View the end cut: Position your cursor near the middle of the part, hold down the left 
mouse button and move left or right along the part, toward the end you want to view. The 
end cut is shown at the same angle as you were viewing the part. Use the Reset button 
to return quickly to the length view. 

• Flip the part: If the print is upside-down when viewing the part, use the method above to 
view the part end-on and continue moving your mouse in the same direction. The part 
will flip and show the print in a readable orientation. 

• Zoom in/out: Use the scroll wheel to zoom in and out. Use the Reset button to return 
quickly to the length view. 

• Once you are zoomed in on a part, use the Pan Left and Pan Right buttons to move 
along the part quickly. 

 

Board Data 
View the optimization for each piece of board. This includes the waste lengths and efficiency 
data per board. The efficiency percentage is essentially how well the program has minimized 
waste on the boards that are used. The efficiency percentage also considers the number of saw 
strokes saved by single or multiple nested cuts.  
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There are several ways to increase the efficiency, including using Lumber Penalties to 
encourage the program to prefer particular board lengths. The best way to customize this to 
your needs is to use manual import for several weeks and review the optimizations. If the 
program is not performing as you would like, we recommend you briefly read the section on 
Lumber Penalties before contacting your MiTek Representative to help you make changes to 
these areas and other settings. 

Board Errors 
See Part Errors. This tab shows the same issues. 

Lumber Data 
View the optimization for each length of lumber. This includes the total board length (footage), 
the total length efficiency and the total waste lengths after all parts have been cut. 
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Assemblies 
View 2D representations of the final fabricated trusses. This includes saw printing. 

The image below represents a customer using AGS printing. 

 
 

Controls 

• Use the scroll wheel to zoom in and out and the scroll bars to view all the trusses. 

Note: This tab will be blank if the file does not include roof/floor graphics. 
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Optimizations 
View the optimization statistics for all manually imported files since the program was opened. 
The statistics from the day or session are deleted when the program is closed. 

If you optimize the same file multiple times with different optimization options, you can compare 
the results to choose the most efficient setup. 

Example: 

 
Columns: 

• Length Efficiency wo (without) Remainders is the overall length of all parts divided by 
the length of all boards. 

• Volume Efficiency wo (without) Remainders is the volume (board feet) of all parts 
divided by the volume of all boards. 

• Remainder Percent is the length of remainder material divided by the length of all 
boards. 

• Total Length Efficiency includes remainders in the overall length of all parts divided by 
the length of all boards. 

• Total Volume Efficiency includes remainders in the volume (board feet) of all parts 
divided by the volume of all boards. 

• Board Feet is the total board foot length for all parts (including remainders). 

• Cost. Physical inventory management is typically maintained in software outside the 
program. However, costs can be added for stock lengths. 

• Quantity of Parts Single Nested is the number of parts that share one common angle 
with another adjacent part on the board. 

• Quantity of Parts Multiple Nested is the number of parts that share two or more 
common angles with another adjacent part on the board.  
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• Saw Strokes Saved indicates how many strokes are not required due to nesting the 
parts. The production rate increases when adjacent parts share common angles, 
because the saw can cut two parts with one stroke.  

 

You can improve or change the optimization in several ways, including: 

• Lumber Penalties 

• Remainders 

• Lower Grade Fill 

• Changing the Optimization Method (Tools > Options > Assembly Profile). 

• Changing the batching options in MVP or CyberSort to increase/decrease the number of 
assemblies that are optimized together. 

Some options will reduce the optimization efficiency. See Out Board Sort Order in Customizing 
Reports for more information. 
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Add Parts 
— 
This option can be used with manual import to add extra parts to the file. For example, you need 
packaging material to secure trusses/wall panels for transportation, but you have no scrap. 

Tip: You can use the remainder options to build a stock of scrap for packaging purposes. 
Setting up remainders saves time by creating the necessary materials from the ends of 
boards (when possible). 

 
1. Import the job file manually. 

2. Go to Tools > Add Part. 

3. Double left-click on a cut shape for the part. 

 
4. Double left-click on the size of the part. 



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 76 of 97 

 
5. Edit the quantity of the part required, add a description for identification, and specify the 

grade and length. Change the stock length if the required length is longer than the 
default stock length. 

 



Software Manual 
 

 

Board Stretcher 
 

   
 
001129 Page 77 of 97 

6. At the bottom of the dialog, left-click Validate and Draw Part and left-click Add.  

 
7. The part is added to the Part Data. 

 
When the file is optimized, additional parts will also be optimized with the job. 
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Edit Parts 
— 
We do not recommend editing the geometry of parts in Board Stretcher. The design file has 
been created according to engineering standards and changes may result in an engineering 
failure. We recommend that the design file is corrected and the corrected version is imported 
into the program. 

There are situations where you may need to change the quantity of a part or parts. 

 

Change the Quantity of a Part 
1. Left-click in the Qty field. 

2. Type the number of parts required. 

3. Repeat as necessary for the parts you want to change. 

4. Select Accept Changes. 

 
Use Cancel Changes to undo all unaccepted changes. 

 

If you want to use a scrap board for the part or the part is pre-cut (e.g., 08-08-10 studs are often 
bought in at length): 

1. Manually import the file. 

2. Edit the Qty field to zero to remove the part from the file. 

3. Select Accept Changes. 

4. Optimize the file and export. 
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If there is an issue with a cut part or parts and you need to recut them: 

1. Manually import the file. 

2. Edit the Qty field to zero for all parts except the part or parts you need to recut. 

3. Select Accept Changes. 

4. Optimize the file and export. 
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Reports 
— 
Lumber/Board Reports Overview 
Reports are created for each saw. There are three reports: Lumber Pick List, Board Pick List 
and Inventory List. 

Lumber List/Lumber Pick List 
This is a report for the picker. All similar lumber is grouped. This makes collecting the lumber 
required quicker and easier. 

Example: 
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Inventory List 
This report shows the available lumber sizes and lengths, grouped by grade. It is the same as 
the Lumber Pick List. “Inventory” is displayed instead of the job file. 

Example: 
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Board Pick List/Board List 
This is a report for the sawyer. Lumber is organized into the order required by the saw. 

Example: 

 
 

Running Reports 

Automatic 
The Lumber Pick List and Board Pick List can be run automatically when a file is exported. The 
reports can be printed and/or saved as PDF files. 

Follow the steps below to enable this feature.  

1. Select the Saw Profile on the sidebar. 

2. Go to Tools > Options > Reports. 

3. Check Lumber List and/or Board List. 

4. Check Printer or PDF as the output type. 

• If you want to print, select your default printer. The printer must already be added 
to your computer in Control Panel (press the Windows key, type “Control Panel”, 
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select the Control Panel app, go to Devices and Printers and follow the steps to 
add a printer). 

• If you want to create a PDF, browse to the file location to save the PDFs. We 
recommend creating a “Pick List” folder in the same location as your 
RemoteFiles folder for Auto Import. 

Manual 
The Lumber Pick List and Board Pick List can be viewed after the file has been optimized. 

Go to the Report tab on the ribbon and select the report required. The Inventory List is always 
available on the Report tab. 

 
There are various tools in the Preview window, including save, export as a different file type, 
print, and tools to edit the page layout, background color and add a watermark. 
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Customizing Reports 

Out Board Sort Order 
This option controls the order of the Board Pick List and the order that the sawyer loads the 
saw.  

There are many different ordering options. The suffix “A” or “D” indicates whether the boards will 
be organized in ascending or descending order. 

The most frequently used options are by Board Length (D) or by Board Length (D), Thickness 
(D), Width (D), Grade (A). These options improve material handling on the Auto Deck and they 
tend to provide good sawyer and picker efficiency.  

Many options will not affect the program’s optimization, but your sawyer’s efficiency may be 
affected. For example, if short lengths are sandwiched between longer lengths, the longer 
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lengths may be prone to racking due to the movement of the Auto Deck. Descending board 
length (Board Length (D)) is a good option when this is an issue. 

You can also choose to output each truss or each truss ID together (using settings from your 
batching program). This option provides the simplest loading and offloading from the saw, but 
the program’s efficiency may be lower because it cannot combine parts from different trusses 
onto the same boards. To use the output order from MVP or CyberSort, select Import File 
Order or Batch Order. 

Company Details on Reports 
To display company information and a logo on reports, go to Tools > Plant and input the details 
required in the dialog. Use Browse to select a logo.  

 
Select Update to save your changes. Select Cancel to close the dialog. The Refresh button will 
undo your changes. 

Note: The logo will be displayed in grayscale on reports. 

 

Error Report Overview 
The Auto Process Error report can be printed to notify you that a file has an error and cannot 
be processed with Auto Import. This method notifies you immediately and saves frequent 
checking of the Auto Invalid Transfer folder location for files with errors. 

To enable the report for a saw, select the Saw Profile on the sidebar and go to File > Options > 
Reports. Under the Errors section, check Send Auto Process Errors to Printer and use 
Select to choose a printer. 
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Lumber Penalties 
— 
Overview 
Lumber Penalties allow you to discourage Board Stretcher from using certain board lengths 
unless the part dimensions require the specific board. Penalties do not directly affect the board 
selection, but they are considered during optimization. 

 

Why Use Lumber Penalties? 

Save Money on Materials 
Using 16ft or 14ft boards is likely to be more cost-effective than using 20ft boards. 20ft boards 
may give you a better optimization than the shorter lengths, but the higher cost of the 20ft 
boards results in higher costs overall. Lumber Penalties allow you to take this into account as 
part of the optimization. 

Limit Use of Low Stock Materials 
You have low stock of 16ft boards and the next delivery is in several weeks. Add a Lumber 
Penalty to 16ft boards to ensure that this length is only selected when necessary. 

Note: Penalties can be added or removed from material as required. 

 

Types of Lumber Penalties 
The penalty can be a Length Penalty or a Cost Penalty. The penalty you use relates to the 
Optimization Basis. Length Penalties are used with Waste optimization; Cost Penalties are used 
with Cost optimization. We recommend using Length Penalties. Cost Penalties require material 
costs to be maintained in the program. 

Length Penalties 
Length Penalties allow you to add a “fake” length of waste to a specific board. This length 
cannot be used for parts; it does not exist and will not be added to the export file. When the 
program optimizes the file, it aims to achieve the least waste. It considers the “fake” lengths of 
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waste when choosing which boards to use. The greater the “fake” length of waste, the greater 
the discouragement for using the boards.  

One of the benefits of this method is that you can penalize a specific board or boards. Not all 
boards need to have penalties assigned to them.  

• If you add a significant Length Penalty to 20ft boards, e.g., 10ft, the program is likely to 
only select this board for parts over 18ft due to the amount of “fake” waste from the 20ft 
board.  

• If you prefer to use more 16ft boards than 18ft boards, you could add a lower Length 
Penalty to the 18ft boards, e.g., 4ft 6in. This will still discourage the program from using 
the 18ft boards, but the “fake” waste is lower, so there is a greater chance that 18ft 
boards will be used if multiple shorter boards create more waste. 

 

Note: If you maintain material costs in the program and choose to use Length Penalties, 
the material costs will not be considered. 

 
Example: 

A job requires No.2 SPF 2x4. The Lumber Yard has a range of lengths available.  

 
Several 20ft and 18ft boards are selected when the file is optimized. This results in high 
efficiency but also higher costs. The lumber usage is shown in Boards > Lumber Data. 
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The company decides that 20ft and 18ft material should only be used when the dimensions of a 
single part require it. They add high length penalties to the 20ft and 18ft boards: 

 
When the file is optimized, 20ft and 18ft materials are not used.  

 
The job is cut at a lower cost. The efficiency and the amount of waste have not changed 
significantly. Depending on the part dimensions and the range of lengths stocked, the efficiency 
may drop if the program has fewer lengths to choose from in the optimization. 
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Set up Length Penalties 
Follow the steps below to set the program to use Length Penalties. 

1. Enable Length Penalties 

1. Select the Saw Profile on the sidebar. 

2. Go to Tools > Options > Assembly Profile. 

3. Set Optimization Basis to Waste. 

4. Set Use Lumber Penalties to Yes. 

2. Create a Length Penalty 

1. Select the Saw Profile on the sidebar. 

2. Go to the Lumber Yard. 

3. Left-click the Length Penalty field and type the amount of “fake” waste to add to the 
board. The image below shows the input for the penalties in the example. 

 

Cost Penalties 
Cost Penalties allow you to add a “fake” cost to a specific board. This cost will not be charged; it 
does not exist and will not be exported to management/inventory software. When the program 
optimizes the file, it aims to achieve the lowest cost. It considers the “fake” cost when choosing 
which boards to use. The greater the “fake” cost, the greater the discouragement for using the 
boards. 

Cost Penalties are not used frequently because the material cost per board for all boards 
needs to be input and kept updated in the program. The dynamic lumber market makes it 
challenging to keep the cost and cost penalties up-to-date. When prices change, you cannot 
account for the price of lumber that was purchased at a different cost. Cost Penalties may not 
be appropriate for multi-site manufacturers, where lumber costs vary between sites. 
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Example: 

• If you add a significant Cost Penalty to 20ft boards, e.g., the board cost is $3 and the 
penalty is $5, the program is likely to only select this board for parts over 18ft due to the 
amount of “fake” cost from the 20ft board. 

• If you prefer to use more 16ft boards than 18ft boards, you could add a lower Cost 
Penalty to the 18ft boards, e.g., the board cost is $2 and the penalty is $1. This will still 
discourage the program from using the 18ft boards, but the “fake” cost is lower, so there 
is a greater chance that 18ft boards will be used if multiple shorter boards cost more. 

Set up Cost Penalties 
Follow the steps below to set the program to use Cost Penalties. 

1. Enable Cost Penalties 

1. Select the Saw Profile on the sidebar. 

2. Go to Tools > Options > Assembly Profile. 

3. Set Optimization Basis to Cost. 

4. Set Use Lumber Penalties to Yes. 

2. Create a Cost Penalty 

1. Select the Saw Profile on the sidebar. 

2. Go to the Lumber Yard. 

3. Left-click the Cost Penalty field and type the dollar amount of “fake” cost to one decimal 
place. As shown in the image below, to input three dollars, type “3”. One dollar fifty cents 
is “1.5”. The image below shows the input for the penalties in the example, plus a 
penalty on 16ft boards. 
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Additional Penalty Options 
The following options are available in Tools > Machine’s Configuration. Do not change these 
settings unless you are asked to do so by a MiTek Representative. Both options have separate 
settings for truss, floor and wall panels. 

Optimize Longest Boards 

The program will use the longest boards available. All Lumber Penalties are ignored.  

 

Optimize for Saw Performance 
The program will use nested cuts to gain efficiency at the saw. If a board has an angled cut that 
matches another angled cut, the program will reorientate the board and nest the cuts. 
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Troubleshooting 
— 
Cannot Log in as an Admin 
There will be an issue with the password if the program is not closed at the end of each 
calendar day. If the admin password is not accepted, use the previous password. 
Alternatively, close the program and reopen it, then use the current password to log in. 

 

Folder Permissions 
You need full read/write access (known as Full control) to any folders used by Board Stretcher. 
If you receive errors that refer to “Application has generated an unhandled exception”, this may 
be due to folder permissions. 

1. In Windows Explorer, go to the folder containing the Board Stretcher installation. If the 
standard locations have been used, this is C:\Program Files (x86), and the program will 
be in a folder called MiTek. 

2. Right-click on the MiTek folder and select Properties. 

3. On the General tab, uncheck Read-only. 

 
4. On the Security tab, select Edit. 
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5. In the Group or user names section, select Users. In the Permissions for Users 

section, check Full control in the Allow column. 

 
6. Select OK to close the dialog. 

7. Select Apply on the dialog that was behind it. 

8. A confirmation dialog will be displayed. Select OK. 
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Note: You may see another dialog about Administrator permissions. Select Continue. 

 

Back up Board Stretcher and its Database 
We recommend that you back up your installation of Board Stretcher and its database before 
installing major Windows updates or before making changes to the drive/location where the 
program and the database are saved. 

Back up the Installation 

The default backup location is the local computer itself:  

C:\Program Files (x86)\MiTek\BoardStretcher\ 

Change this location to a network directory to ensure that your data is safe if there is an issue 
with the local computer. 

The Board Stretcher .exe and .config files are saved in Backup.zip and a full copy of the Board 
Stretcher folder is saved in the location above, in the tmp folder. 

To backup your installation of Board Stretcher: 

1. Go to Help > About. 

2. Select Backup. 

Note: You may see some error dialogs. Select Yes or OK to continue. 
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Back up the Database 
Typically, your Board Stretcher SQL database will be backed up at the same time as other SQL 
databases used for MVP, etc. If there is no backup plan, contact your IT to set this up.  

One backup method that we recommend is a seven-day rolling backup, set up as a batch file 
Windows Task on the server. Each backup includes the day, i.e., MachineryMonday.bak, 
MachineryTuesday.bak, etc. and these files are overwritten the following week. This method can 
be used with full SQL or SQL Express. 

Ensure that the backup location is a network directory to keep your data safe if there is an issue 
with the local computer. 

 

Find Software and Database Version 
A MiTek Representative may ask you for the version you are using to help troubleshoot issues. 
Go to Help > About. 

 
 

Renew the Program License 
The license remains active while the computer is connected to the internet and the program is 
being used. The license will expire if the computer is not connected to the internet and the 
program is not started for 21 days. You can also force a license renewal, if you know you will 
have an intermittent internet connection for a period of time. 

To renew the license: 

1. Go to Help > About. 

2. Select Renew. 

The license is now renewed for another 21 days. 
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Logs and Machine Configuration 

Logs 
A MiTek Representative may ask you to open or save the Machine logs to help troubleshoot 
issues. There are four different logs: Complete, Import, Run, and Error.  

1. Go to Report > Machine’s Logs and select the requested log. 

 
2. In the Log window, select Save as on the bottom toolbar. 

 
3. A file name will be suggested; change it if required. The default save location is 

C:\Program Files (x86)\MiTek\BoardStretcher\Log. 
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Machine Configuration 
A MiTek Representative may ask you to open and edit the Machine Configuration to help 
troubleshoot issues. Go to Tools > Machine’s Configuration. 

 
This is a view of the settings in the SQL database. Do not edit these fields unless you are asked 
to do so by a MiTek representative. 

 

Contact MiTek 
If you have a Board Stretcher issue that is not resolved by this manual, please contact MiTek 
Automation Support on 866-648-3587. 

The MiTek representative may request a log or a copy of your database to help troubleshoot the 
issue. 

To send a log: 

1. Go to Help > Support. 

2. On the Report Problem tab, input the relevant details and attach any relevant job files. 

3. Select Send. 

To email a copy of your database: 

1. Go to Help > Email Office Troubleshooting Data. 

2. Input the relevant details. 

3. Select OK. 
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